Resolved
Performance are back to normal levels.
We apology for any inconvenience this might have caused you.
Monitoring
Performance metrics are going back to normal values. We continue to monitor the situation
Investigating
We are experiencing degraded performance on the Manager Dashboard. We are investigating.