Resolved
All Dashboard functionalities have recovered. We identified the cause in a faulty dependency update and fixed it.
We apologize for the disruption and for any issue this might have caused you.
Identified
We have identified the root cause and are deploying a fix.
Investigating
We are currently investigating reports of errors while using the Manager Dashboard.